XML installation error

If you face an XML installation error when you try to install the component then you probably trying to install it on a Joomla! release 1.5. SP Upgrade component can only be installed on a Joomla! 1.6, 1.7, 2.5, or 3.x and above. From there then you migrate from the 1.5 site. Read User Guide - SP Upgrade for more details.